محدود سازی پهنای باند بر روی IP کاربران با استفاده از Mikrotik Queue

محدود سازی پهنای باند بر روی IP کاربران با استفاده از Mikrotik Queue

ارسال شده در تاریخ : ۵ مهر, ۱۳۹۵

محدود سازی پهنای باند بر روی IP کاربران با استفاده از Mikrotik Queue

سوالی که خیلی مواقع ازم پرسیده میشه اینه که چطوری میتونیم پهنای باند رو در یک شبکه کنترل کنیم بطوریکه یک سیستم نتونه تمام پهنای باند را استفاده کند. این نیاز بیشتر در سایت های کامپیوتری، کافی نت ها و گیم نت ها مطرح می شه که تعداد زیادی کامپیوتر قراره با یک پهنای باند معمولا محدود به اینترنت دستیابی داشته باشن.
یکی از راه های ساده ای که برای این کار میتونم پیشنهاد بدم استفاده از قابلیت Queue در میکروتیک است. واژه Queue به معنی “صف” است و همانطور که در ویکی میکروتیک عنوان شده :

 

“Queues are used to limit and prioritize traffic”


از این قابلیت برای محدود سازی و اولویت بندی ترافیک در راه اندازی شبکه استفاده می شه.
سعی دارم در این مقاله، نحوه محدود سازی پهنای باند بر اساس ip در یک شبکه رو توضیح بدم. البته شما میتونید با مراجعه به ویکی میکروتیک که لینکش رو ذیل این پاراگراف قرار دادم، با این موضوع بیشتر آشنا بشید و خدمات شبکه خودتون رو بصورت اختصاصی تر و مطابق میلتون محدود کنید:

 

http://wiki.mikrotik.com/wiki/Manual:Queue


خوب، بریم سر اصل مطلب. فرض می کنیم که میخوایم در شبکمون چند تا از سیستم ها حداکثر بتونن ۵۱۲ کیلوبیت بر ثانیه از پهنای باند پشتیبانی شبکه خارجی (مثلا اینترنت) رو استفاده کنن (۵۱۲k دانلود ریت و ۲۵۶k آپلود ریت). در این بین ممکنه بخوایم بعضی از سیستم ها پهنای باند کمتری بتونن استفاده کنن مثلا یک سیستم بیشتر از ۱۲۸k نتونه پهنای باند بکشه سمت خودش.
فرض میکنیم کاربرای ما دارای رنج آی پی ۱۹۲٫۱۶۸٫۱٫۰/۲۴ هستن. توجه داشته باشید که تعیین محدودیت های پایینتر برای بعضی از کاربران فقط در صورتی که محدودیت اصلی رو به عنوان Parent قرار بدیم انجام پذیره.
با فرض بر اینکه رنج آی پی هایی که می خوایم محدودیت پهنای باند را روی آنها اعمال کنیم ۱۹۲٫۱۶۸٫۱٫۰/۲۴ باشه به ترتیب مراحل زیر رو انجام می دیم :
ابتدا کل subnet mask رو در یک queue کلی قرار می دهیم و یک پهنای باند کلی برای کل مجموعه در نظر می گیریم :

 

/queue simple
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
 disabled=no interface=all limit-at=0/0 max-limit=256k/512k name=master \
 packet-marks="" parent=none priority=3 queue=default-small/default-small \
 target-addresses=192.168.1.0/24 time=8h30m-19h30m,sun,mon,tue,wed,thu,sat \
 total-queue=default-small



بعد از ایجاد یک queue کلی، باید برای تک تک کاربر هایی که میخواهیم پهنای باند خاصی رو بهشون نسبت بدیم، یک queue جدا تعریف کنیم و اون رو زیر مجموعه queue اصلی قرار بدیم. من یک queue برای آی پی ۱۹۲٫۱۶۸٫۱٫۲ ایجاد می کنم و اون رو روی ۱۲۸/۱۲۸ Kb می بندم و parent اون رو میزارم master :

 

/queue simple
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
 disabled=no interface=all limit-at=0/0 max-limit=128k/128k name=\
 "Erfan Abedi" packet-marks="" parent=master priority=8 queue=\
 default-small/default-small target-addresses=192.168.1.2/32 total-queue=\
 default-small


شما هم می تونید برای تک تک کاربرایی که به صورت دستی و یا DHCP به شبکه وصل هستن این queue ها رو ایجاد کنید.
توجه:
۱) این روش، یک روش ساده و ابتدایی برای تقسیم پهنای باند در میکروتیک بوده و برای تقسیم پهنای باند بصورت بهینه تر و تعاریف پهنای باند شناورد و سایر الگوریتم ها، میتوان از قابلیت های Queue tree و PCQ در میکروتیک استفاده نمود که در آموزش های آتی به این مباحث نیز خواهیم پرداخت.
۲) برای اختصاص ip ثابت به کامپیوتر ها – که ممکن است پس از مطالعه این آموزش به آن نیاز پیدا کنید- به این پست مراجعه نمایید

تماس با ما

هر سوالی داشتید با ما در میان بگذارید